Request for more users...

distributed filesystem with a I2P plugin
Post Reply
User avatar
quark
Posts: 25
Joined: 18 Jan 2020 05:44

Request for more users...

Post by quark »

Hi, I would like to encourage more i2pers to setup Tahoe on there systems. It seems that this project is weak. i2p must keep a strong image if it is going to grow. So please if you can set it up and run it. Thank you.
quark
Shinzon
Posts: 2
Joined: 12 Apr 2018 00:16

Re: Request for more users...

Post by Shinzon »

Hi Quark,

I have been running tahoe-lafs [i2p] for a very long time.

I tried to upgrade it via pip but I am having a problem with pycryptopp 0.7.1.

I was upgrading it in hopes of better connectivity and speed (I have a wide network pipe and give quite a bit to the i2p community).

Here is what I am getting:

Code: Select all

[tstrike39@zabbixserviio ~]$ pip install -U pyopenssl
Defaulting to user installation because normal site-packages is not writeable
Collecting pyopenssl
  Downloading pyOpenSSL-19.1.0-py2.py3-none-any.whl (53 kB)
     |████████████████████████████████| 53 kB 351 kB/s 
Requirement already satisfied, skipping upgrade: six>=1.5.2 in /usr/local/lib/python3.6/site-packages (from pyopenssl) (1.14.0)
Collecting cryptography>=2.8
  Downloading cryptography-2.9.2-cp35-abi3-manylinux2010_x86_64.whl (2.7 MB)
     |████████████████████████████████| 2.7 MB 2.1 MB/s 
Collecting cffi!=1.11.3,>=1.8
  Downloading cffi-1.14.0-cp36-cp36m-manylinux1_x86_64.whl (399 kB)
     |████████████████████████████████| 399 kB 3.0 MB/s 
Collecting pycparser
  Downloading pycparser-2.20-py2.py3-none-any.whl (112 kB)
     |████████████████████████████████| 112 kB 4.4 MB/s 
Installing collected packages: pycparser, cffi, cryptography, pyopenssl
Successfully installed cffi-1.14.0 cryptography-2.9.2 pycparser-2.20 pyopenssl-19.1.0
[tstrike39@zabbixserviio ~]$ pip3 install -U tahoe-lafs[i2p]
Defaulting to user installation because normal site-packages is not writeable
Collecting tahoe-lafs[i2p]
  Using cached tahoe-lafs-1.12.1.tar.gz (1.6 MB)
Requirement already satisfied, skipping upgrade: setuptools>=11.3 in /usr/lib/python3.6/site-packages (from tahoe-lafs[i2p]) (39.2.0)
Collecting zfec>=1.1.0
  Using cached zfec-1.5.3.tar.gz (79 kB)
Collecting simplejson>=1.4
  Using cached simplejson-3.17.0.tar.gz (83 kB)
Collecting zope.interface!=3.6.3,!=3.6.4,>=3.6.0
  Using cached zope.interface-5.1.0-cp36-cp36m-manylinux2010_x86_64.whl (234 kB)
Collecting foolscap>=0.12.6
  Using cached foolscap-20.4.0-py2.py3-none-any.whl (313 kB)
Collecting pycrypto!=2.2,!=2.4,>=2.1.0
  Using cached pycrypto-2.6.1.tar.gz (446 kB)
Collecting pycryptopp>=0.6.0
  Using cached pycryptopp-0.7.1.869544967005693312591928092448767568728501330214.tar.gz (2.0 MB)
    ERROR: Command errored out with exit status 1:
     command: /usr/bin/python3 -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-yq4oih4a/pycryptopp/setup.py'"'"'; __file__='"'"'/tmp/pip-install-yq4oih4a/pycryptopp/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pip-pip-egg-info-hvdxb0t9
         cwd: /tmp/pip-install-yq4oih4a/pycryptopp/
    Complete output (6 lines):
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/tmp/pip-install-yq4oih4a/pycryptopp/setup.py", line 94
        print "Did not locate libcryptopp in the usual places."
                                                              ^
    SyntaxError: Missing parentheses in call to 'print'. Did you mean print("Did not locate libcryptopp in the usual places.")?
    ----------------------------------------
ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.
Shinzon
Posts: 2
Joined: 12 Apr 2018 00:16

Re: Request for more users...

Post by Shinzon »

Also I have about 7 files uploaded. I like using i2p and tahoe allows me to hide away some of my precious documents.
Post Reply