I2P bote new build from mhatta working

Post Reply
echelon
Posts: 189
Joined: 10 Feb 2018 13:36

I2P bote new build from mhatta working

Post by echelon »

Hi

mhatta did fixed some issues of i2p-bote and made a new pugin I2P-Bote Version 0.4.8 .1
For me it seems to work under debian I2P version 0.9.45.
You need to:
- fetch .su3 file from https://people.debian.org/~mhatta/i2pbote.su3
- fetch mhatta pub key from https://people.debian.org/~mhatta/mhatt ... il.i2p.crt
- copy over the mhatta_at_mail.i2p.crt pubkey to i2p/certificates/plugin/
- visit the install plugin page on http://127.0.0.1:7657/configplugins
- select "installation from file" browse and choose the new downloaded .su3 file, click on "Install Plugin from File"

And it should have installed and should run already.

Edit:
Source repo on https://github.com/mhatta/i2p.i2p-bote
Soon (tm) to be mirrored in git.idk.i2p

echelon
User avatar
zzz
Posts: 139
Joined: 31 Mar 2018 13:15

Re: I2P bote new build from mhatta working

Post by zzz »

I glanced at the changes on his github, there was no rev that claimed to fix anything, just updates of dependencies and things, so it's not apparent to me what the fix is. In particular there's no reference to any github or trac tickets. There's a couple of trac tickets that we thought were fatal bugs, if I remember right. Would be nice to have more test reports below, and a comment from mhatta on why things work now.
User avatar
yaks
Posts: 3
Joined: 17 May 2020 03:25

Re: I2P bote new build from mhatta working

Post by yaks »

Just to chime in, anyway for this plugin to work i've installed and will not open

Error 404: /i2pbote/index.jsp not found.
flywheel
Posts: 3
Joined: 16 Jun 2020 20:43

Re: I2P bote new build from mhatta working

Post by flywheel »

yaks wrote:
08 Jun 2020 00:03
Just to chime in, anyway for this plugin to work i've installed and will not open

Error 404: /i2pbote/index.jsp not found.
This might be helpful, I had to do this, (summary)
Inside your " ~/.i2p/plugins/i2pbote/console/webapps/i2pbote.war " file, under
WEB-INF/libs there are 3 java (tomcat) files , that don't run under jetty, so you need to remove them, or move them out of the war archive, Then it will install...

I have 'mc' installed, so it was a matter of navigating to that file, highlighting and opening it, and then just finding and deleting the *.jar files... It's easier than extracting.

More info. can be found here:

https://trac.i2p2.de/ticket/2644

I hope it helps!
Post Reply